Меню

Как настроить микротик мультикаст

Как настроить IPTV на MikroTik

Установка пакета multicast

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный пакет multicast. Для этого выполните следующее:

  1. Перейдите на оффициальный сайт MikroTik по ссылке http://www.mikrotik.com/download;
  2. Определите, к какой серии относится ваш роутер, и версию операционной системы RouterOS, установленную на роутере. Если на сайте нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии. Как это сделать можно прочитать в инструкции Как обновить MikroTik RouterOS;
  3. Нажмите на ссылку напротив Extra Packages и необходимой версии RouterOS, чтобы скачать дополнительные пакеты;

После перезагрузки в меню System — Packages должен появиться модуль multicast.

Настройка IGMP Proxy

Выполним настройку IGMP Proxy на MikroTik.

Откройте меню Routing — IGMP Proxy и нажмите синий плюсик, чтобы указать на какой порт приходит IPTV.

В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream.

В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16.

Я настраивал IPTV для Maxnet, и у меня все заработало c Alternative Subnets 0.0.0.0/0. Но так лучше не делать. Используйте 0.0.0.0/0 только если не смогли найти необходимую подсеть.

После ввода параметров нажмите кнопку OK.

Еще раз нажмите синий плюсик, чтобы указать на какие порты передавать IPTV.

В выпадающем списке Interface выберите порт, на который нужно пробросить IPTV, и нажмите кнопку OK. В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

Нажмите кнопку Settings и поставьте галочку напротив Quick Liave. Это позволит быстро переключаться между каналами.

Настройка Firewall

Чтобы фаервол пропускал IPTV, необходимо добавить разрешающие правила. Откройте меню New Terminal.

Выполните в терминале следующие команды:

/ip firewall filter add action=accept chain=input comment=»Allow IGMP» disabled=no in-interface=ether1 protocol=igmp

/ip firewall filter add action=accept chain=forward comment=»IPTV UDP forwarding» disabled=no dst-port=1234 protocol=udp

ether1 — это интерфейс, на который приходит IPTV от провайдера. Если ваше имя отличается, укажите необходимое.

После этого откройте меню IP — Firewall и перейдите на вкладку Filter Rules. Созданные правила перетяните кнопкой мыши вверх выше запрещающих.

Настройка Wi-Fi

Если вы транслируете IPTV по Wi-Fi, то необходимо выполнить следующие настройки.

  1. Откройте меню Wireless.
  2. Перейдите на вкладку Interfaces.
  3. Откройте двойным щелчком беспроводной интерфейс wlan1.
  4. Перейдите на вкладку Wireless.
  5. Нажмите кнопку Advanced Mode.

Найдите параметр WMM Support и выберите enabled. Он включит поддержку Wi-Fi multimedia. Если у вас много клиентов, то его лучше не включать, поскольку один клиент может мультикастом съесть весь канал.

В параметре Multicast Helper выберите full. Это позволит отправлять мультикаст пакеты по MAC адресам клиентам, подключенным к Wi-Fi.

После этого нажмите кнопку OK.

На этом настройка IPTV на MikroTik окончена.

Источник



Как настроить IPTV на роутере Mikrotik

Mikrotik IPTV – это устройство для подключения к телевещанию, которое требует дополнительных на.

Mikrotik IPTV – это устройство для подключения к телевещанию, которое требует дополнительных настроек. Перед этим сбрасывается ранее установленная конфигурация.

Сброс настроек роутера

Сбросить настройки роутера Микротик IPTV можно несколькими способами:

  • Через кнопку Reset на задней стороне устройства.
  • Нажатием на кнопку в специальном отверстии в плате роутера.
  • С помощью джампера.

Первый вариант самый простой и доступен пользователям большинства роутеров.

Через кнопку Reset

Для сброса настроек до заводских параметров, например на моделях линейки Hap Lite, выполните инструкцию:

  1. Выключите блок питания.
  2. Найдите кнопку «Reset» на обратной стороне устройства, зажмите ее и не отпускайте.
  3. Запустите роутер, подключив блок питания.
  4. Дождитесь, пока не замигает лампа «ACT», затем сразу же отпустите кнопку «Reset».

Не дожидайтесь, пока лампочка перестанет мигать. Если жать слишком долго, то начнется процедура переустановки операционной системы.

Через отверстие в плате

Современные устройства с платой «RouterBOARD» имеют отверстие для доступа к кнопке сброса настроек, которая обозначена двумя полумесяцами.

  1. Отключите блок питания.
  2. Переверните роутер для поиска отверстия. Если его нет, то придется открыть крышку устройства.
  3. Замкните контакты полумесяцев отверткой и не убирайте ее до момента сброса настроек.
  4. Подключите блок питания.
  5. Уберите отвертку от контактов, когда замигает лампа «ACT».

Подобный вариант восстановления заводских параметров сложнее предыдущего, поэтому используется только при отсутствии иных способов.

Сброс джампером

Инструкция для сброса параметров джамперов актуальна только для старых моделей роутеров.

  1. Отключите блок питания.
  2. Найдите джампер с надписью «Soft Reset». Если его нет, то придется открыть крышку роутера.
  3. Зажмите две части джампера между собой отверткой или перемычкой. Не убирайте ее, пока не произойдет сброс.
  4. Подключите блок.
  5. Дождитесь сигнала о восстановлении заводских параметров и уберите перемычку.

Если не убрать перемычку, то каждый новый запуск будет сопровождаться сбросом настроек.

Установка IPTV

Настройка телевещания на роутере Микротик начинается с установки новой операционной системы с подходящей версией.

  1. Нужно скачать RouterOS и установить программу на компьютер. Это самая актуальная версия ОС для устройств Микротик.
  2. Откройте настройки устройства с помощью утилиты WinBox.
  3. Найдите кнопку «Files», перенесите туда файл из пакета с названием «multicast».
  4. Откройте раздел «System», найдите пункт «Reboot» или же введите в командную строку следующие символы: «system reboot». Это перезапустит роутер для того, чтобы изменения вступили в силу.
  5. Откройте пункт «System», в контекстном меню найдите раздел «Packages». Если в нем появился файл из пакета, то настройка мультикаста завершена.

Для просмотра телевидения этого мало, поэтому настройка Mikrotik IPTV продолжается.

Настройка IGMP Proxy

Настройка IGMP на Mikrotik IPTV связана с указанием данных подсетей провайдеров, которые нужны для приема сигнала. Если информации об этом у пользователя нет, то приходится перебирать «стандартные» варианты.

  1. Через утилиту откройте раздел «Routing», затем перейдите в «IGMP Proxy».
  2. В открывшемся окне найдите строку «Interface», укажите в нем номер порта, куда подключен интернет.
  3. В разделе «Alternative Subnets» напишите номер подсети провайдеров, добавьте галочку в разделе «Upstream».

В качестве «стандартных» вариантов можно использовать следующие:

  • 10.0.0.0/8;
  • 192.168.0.0/16;
  • 172.16.0.0/12.
  1. Остальные параметры оставьте по умолчанию, нажмите кнопку «ОК».
  2. Кликнете по изображению «+» для добавления портов ТВ.
  3. В поле «Interface» укажите порт роутера, который соединен с телевизором.
  4. Галочка не ставится, подсеть не прописывается. Нажмите кнопку «Ок».
  5. В окне «IGMP Proxy» найдите кнопку «Settings», нажмите на нее. Поставьте галочку в строке «Quick Leave», кликните «ОК».

Настройка прокси на этом завершена. При соблюдении всех указаний роутер будет принимать сигнал и передавать его на ТВ.

Настройка Firewall

На устройстве Микротик настройка IPTV осложняется встроенной защитой, которая может не пропустить сигнал телевещания. Поэтому дополнительно изменяются параметры фаервола.

  • В главном меню утилиты найдите раздел «New Terminal».
  • Введите поочередно 3 строки программного кода, где вместо «*название порта входа*» прописывается порт, указанный в строке «Interface» на втором шаге предыдущей инструкции:

/ip firewall filter add action=accept chain=input comment=»Allow IGMP» disabled=no in-interface=*название порта входа* protocol=igmp

/ip firewall filter add action=accept chain=input comment=»IPTV UDP incoming» disabled=no dst-port=1234 in-interface=*название порта входа* protocol=udp

/ip firewall filter add action=accept chain=forward comment=»IPTV UDP forwarding» disabled=no dst-port=1234 protocol=udp

  • После выполнения программного кода новые правила для фаервола добавятся в меню «Firewall», который находится на вкладке «IP».
  • Перенесите их в самый вверх, чтобы их приоритет стал выше запрещающих строк.

После этого можно просматривать телеканалы. Остальные настройки понадобятся тем, кто подключает роутер и телевизор по Wi-Fi.

Настройка Wi-Fi

Для настройки соединения Mikrotik Hap Lite IPTV и телевизора по Wi-Fi требуется выполнить инструкцию:

  1. В главном меню выберите раздел «Wireless».
  2. В открывшемся окне активируйте вкладку «Interface».
  3. Дважды кликните по имеющемуся подключению.
  4. На вкладке «Wireless» нажмите на кнопку «Advanced Mode».
  5. Установите режиме «Enable» в строке «WMM Support».
  6. Выберите «Full» в списке «Multicast Helper».
  7. Нажмите кнопку «ОК».

Если телевизор видит точку доступа роутера Mikrotik – настройка IPTV завершена. Остается подключиться к сети и просматривать телевещание местного провайдера.

Источник

Записки IT специалиста

Технический блог специалистов ООО»Интерфейс»

  • Главная
  • Настройка IPTV в роутерах Mikrotik на примере Ростелеком

Настройка IPTV в роутерах Mikrotik на примере Ростелеком

IPTV в настоящее время стал стандартом де факто, практически полностью вытеснив «классическое» кабельное телевидение. Сегодня практически любой провайдер предлагает комплексные тарифные планы, включающие телевидение и интернет, предоставляет в аренду уже настроенное оборудование и вообще всякими способами стремится завлечь абонента в свои сети. И это хорошо, здоровая конкуренция снижает цены и повышает качество услуг. Но как быть, если вы предпочитаете настраивать свое сетевое оборудование самостоятельно? Сегодня мы как раз поговорим об этом.

Освоить MikroTik вы можете с помощью онлайн-курса «Настройка оборудования MikroTik». В курсе изучаются все темы из официальной программы MTCNA. Автор — официальный тренер MikroTik. Материал подходит и тем, кто уже давно работает с оборудованием MikroTik, и тем, кто еще не держал его в руках. В состав входят 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Подключение IPTV-приставки непосредственно в сеть провайдера

Самый простой и нетребовательный к ресурсам способ смотреть IPTV, полностью оправдан, если ваша приставка не имеет никаких иных функции, которые требуют доступа к ресурсам локальной сети. Если вспомнить былые времена, то многие провайдеры при подключении IPTV ставили перед роутером простой свитч, куда включали IPTV-приставку, фактически мы повторим эту схему, но с использованием возможностей Mikrotik.

Прежде всего определим порт, в который будет подключена приставка и выведем его из моста локальной сети (если он туда включен), в нашем случае это будет порт ether4. Для этого перейдем в Bridge — Ports и удалим запись для нужного порта.

Затем создадим новый мост и введем в него порт приставки и внешний порт, смотрящий в сторону провайдера:

Чтобы избежать возможных конфликтов с активным оборудованием провайдера отключим в свойствах моста протокол RSTP:

Если вы используете для подключения к интернету коммутируемое подключение, то в его свойствах вместо внешнего интерфейса (ether5 в нашем примере) следует указать интерфейс моста bridge2. В данном случае это будет PPPoE подключение провайдера Ростелеком.

При использовании иных методов доступа в интернет не забудьте изменить порт внешнего подключения с ether5 на bridge2, а также внести аналогичные изменения в правила файрволла, при коммутируемом подключении (PPPoE) делать этого не надо.

После чего достаточно перезагрузить приставку, и она самостоятельно «разберется» с настройками, после чего вы сможете полноценно пользоваться услугой IPTV вашего провайдера.

Настройка IGMP Proxy

Однако предложенный выше способ может быть не всегда приемлем, вместо приставки могут использоваться иные, более функциональные устройства: SmartTV, TV BOX на Android и т.д. и т.п., которым нужно обеспечить доступ к ресурсам локальной сети. Также приставка может быть подключена не напрямую к роутеру, а через дополнительный коммутатор, либо вы еще по какой-либо причине не хотите выводить устройство за пределы домашней сети. В этом случае потребуется настройка IGMP Proxy, который обеспечит перенаправление мультикастового потока IPTV в локальную сеть и прохождение IGMP-пакетов для управления этим потоком.

В базовой поставке RouterOS необходимая функциональность отсутствует и нам потребуется установить дополнительный пакет multicast. Для этого на официальном сайте следует скачать набор Extra packages для своей версии прошивки и архитектуры. Если у вас более старая версия RouterOS, то обновите ее.

Затем откройте Winbox, перейдите в раздел Files и загрузите на устройство пакет multicast, это можно сделать простым перетаскиванием, затем перезагрузите роутер.

Если вы настраиваете IPTV от Ростелеком, то на внешнем интерфейсе, смотрящем в сторону провайдера, у вас не будет IP-адреса, так как протокол PPPoE, через который осуществляется доступ в интернет, работает на канальном уровне и не требует IP-адресов. Для работы IPTV внешнему интерфейсу необходимо будет присвоить адрес. Поддержка Ростелекома предписывает использовать адрес 1.0.0.1/30, на наш взгляд использование данного адреса не совсем корректно (он не является приватным) и, как показывает практика, вы можете присвоить интерфейсу любой адрес, но официальные рекомендации стоит иметь ввиду, особенно если больше ничего не помогает.

Если вы предпочитаете работу в консоли, то выполните:

Теперь перейдем в раздел Routing — IGMP Proxy и добавим внешний интерфейс, на который приходит IPTV. В поле Interface укажите внешний интерфейс, в нашем случае ether5, в поле Alternative Subnets0.0.0.0/0 и установите флажок Upstream.

Что касается Alternative Subnets, то данная настройка требует некоторых пояснений, в ней указывается подсеть, из которой осуществляется вещание, так как Ростелеком использует собственную изолированную сеть, то указание 0.0.0.0/0, т.е. принимать любые потоки, будет оправдано. Если же вы настраиваете IPTV на интерфейсе, смотрящем непосредственно в интернет, то желательно явно указать подсеть, уточнив ее в техподдержке провайдера.

Затем добавим внутренний интерфейс, куда следует перенаправить IPTV-поток, в этом качестве укажем мост локальной сети, никаких других настроек делать не нужно.

После чего нажмите кнопку Settings и установите флажок Quick Leave для быстрого переключения между каналами.

Также можно быстро выполнить все приведенные выше настройки через терминал:

Теперь осталось настроить правила брандмауэра для прохождения IPTV-трафика. Для этого добавим следующие записи: Chain — input, Protocol — igmp, In. Interface — ether5, так как по умолчанию действие accept, то на закладку Action можно не переходить. Данное правило разрешить входящий IGMP-трафик на внешнем интерфейсе.

Второе правило разрешит транзитный IPTV-трафик: Chain — forward, Protocol — udp, Dst. Port — 5000, In. Interface — ether5. Отдельного пояснения требует номер порта, Ростелеком использует порт 5000, для других провайдеров следует уточнить это значение в поддержке.

Также не забудьте перетащить данные разрешающие правила выше запрещающих в каждой из цепочек.

В терминале эти же правила добавляются командами:

После выполнения данных настроек перезагрузите IPTV-приставку и, если вы не допустили ошибок, все должно заработать.

IPTV через Wi-Fi

Скажем сразу, использовать беспроводную сеть, особенно в диапазоне 2,4 ГГц, для доставки IPTV — не самая удачная идея. Следует понимать, что Wi-Fi является разделяемой средой и вы делите доступную пропускную способность не только с клиентами вашей сети, но и с устройствами соседних сетей, работающих в том же частотном диапазоне. Проще говоря, даже если ваши собственные устройства не занимают Wi-Fi, то за стеной может оказаться ноутбук соседа, которые на этом же самом канале качает торренты, поэтому прием IPTV, особенно с HD-качеством в таких условиях может оказаться затруднительным.

Но если вы все-таки решили транслировать IPTV через Wi-Fi, то выполните следующие настройки: перейдите в свойства беспроводного интерфейса на закладку Wireless и перейдите в режим Advanced Mode.

Затем установите значения опций: WMM Support — enabled и Multicast Helper — full.

Это включит Wi-Fi multimedia и позволит отправлять мультикаст-пакеты на mac-адреса беспроводных клиентов, но не забывайте, что вы делите полосу пропускания не только между своими устройствами, поэтому работа таких клиентов может не соответствовать ожиданиям, особенно в городских условиях.

Освоить MikroTik вы можете с помощью онлайн-курса «Настройка оборудования MikroTik». В курсе изучаются все темы из официальной программы MTCNA. Автор — официальный тренер MikroTik. Материал подходит и тем, кто уже давно работает с оборудованием MikroTik, и тем, кто еще не держал его в руках. В состав входят 162 видеоурока, 45 лабораторных работ, вопросы для самопроверки и конспект.

Дополнительные материалы:

Помогла статья? Поддержи автора и новые статьи будут выходить чаще:

Или подпишись на наш Телеграм-канал:

Источник

Читайте также:  Как настроить станцию мини без вай фай