Меню

Как настроить регистр имени

Программная работа с регистрами сведений

Регистры сведений в 1С предназначены для хранения произвольных данных в разрезе нескольких измерений и, при необходимости, в разрезе времени. Рассмотрим подробнее работу с этим прикладным объектом.

Предназначение регистра сведений

Регистры сведений в 1С — это прикладные объекты конфигурации для хранения данных в структурированном виде (в разрезе измерений). Например, в регистре сведений можно хранить курсы валют в разрезе валют, цены номенклатуры в разрезе номенклатур, ФИО физических лиц в разрезе физических лиц и т.д.

При проектировании разработчик указывает необходимость хранения данных в разрезе времени и минимальную периодичность, с которой записи будут храниться в регистре:

Регистры сведений, для которых указана периодичность, называются периодическими.

Изменение данных в регистре может осуществляться как вручную, так и при помощи документов. Режим записи в регистр определяет разработчик на этапе проектирования:

Физически регистр сведений представляет собой таблицу, в которой хранятся следующие данные:

  • измерения — описывают разрезы, в которых хранится информация;
  • период — поле, используемое для разворота данных по времени. Поле добавляется автоматически при указании свойства «Периодичность», отличного от «Непериодический»;
  • регистратор — поле, используемое для хранения документа, с которым связана запись. Поле добавляется автоматически при указании свойства «Режим записи» в значение «Подчинение регистратору»;
  • ресурсы — непосредственно хранят информацию для комбинации измерений;
  • реквизиты — дополнительная произвольная информация, относящаяся к конкретной записи регистра.

Для всех регистров сведений обеспечивается контроль уникальности записей, т.е. в регистре не может быть двух одинаковых записей. Одинаковыми считаются записи, у которых совпадают значения измерений, период (если регистр периодический) и регистратор (если регистр подчинен регистратору).

Добавление записей

Программно добавить записи в регистр сведений можно при помощи:

  • объекта НаборЗаписей ;
  • объекта МенеджерЗаписи .

Объект МенеджерЗаписи можно использовать только для работы с независимыми регистрами. Причем можно обрабатывать только одну запись. Объект предназначен в основном для интерактивной работы, но программно с ним также можно работать. На системном уровне МенеджерЗаписи использует объект НаборЗаписей .

Общая схема добавления записей в регистр сведений при помощи объекта НаборЗаписей выглядит так:

  1. создание объекта НаборЗаписей ;
  2. наложение отборов на измерения, период (если регистр периодический) и регистратора (если регистр подчинен регистратору);
  3. добавление и заполнение значений полей записей;
  4. запись набора записей.

// Добавление записи в независимый непериодический регистр сведений
НаборЗаписей = РегистрыСведений . ВерсииПодсистем . СоздатьНаборЗаписей (); // Этап 1
НаборЗаписей . Отбор . ИмяПодсистемы . Установить ( ИмяПодсистемы ); // Этап 2
// Этап 3
НоваяЗапись = НаборЗаписей . Добавить ();
НоваяЗапись . ИмяПодсистемы = ИмяПодсистемы ;
НоваяЗапись . Версия = НомерВерсии ;
НаборЗаписей . Записать (); // Этап 4

// Добавление записи в независимый периодический регистр сведений
НаборЗаписей = РегистрыСведений . КурсыВалют . СоздатьНаборЗаписей (); // Этап 1
// Этап 2
НаборЗаписей . Отбор . Валюта . Установить ( Доллар );
НаборЗаписей . Отбор . Период . Установить ( НачалоДня ( ТекущаяДата ()));
// Этап3
НоваяЗапись = НаборЗаписей . Добавить ();
НоваяЗапись . Период = ТекущаяДата ();
НоваяЗапись . Валюта = Доллар ;
НоваяЗапись . Курс = 57.92 ;
НоваяЗапись . Кратность = 1 ;
НаборЗаписей . Записать (); // Этап 4

Общая схема добавления записей в регистр сведений при помощи объекта МенеджерЗаписи выглядит так:

  1. создание объекта МенеджерЗаписи ;
  2. заполнение значений полей записи;
  3. запись записи.

// Добавление записи в независимый непериодический регистр сведений
Запись = РегистрыСведений . ВерсииПодсистем . СоздатьМенеджерЗаписи (); // Этап 1

// Этап 2
Запись . ИмяПодсистемы = ИмяПодсистемы ;
Запись . Версия = НомерВерсии ;

Запись . Записать (); // Этап 3

// Добавление записи в независимый периодический регистр сведений
Запись = РегистрыСведений . КурсыВалют . СоздатьМенеджерЗаписи (); // Этап 1

// Этап 2
Запись . Период = ТекущаяДата ();
Запись . Валюта = Доллар ;
Запись . Курс = 57.92 ;
Запись . Кратность = 1 ;

Запись . Записать (); // Этап 3

Изменение записей

Изменять существующие записи регистров сведений возможно при помощи объектов НаборЗаписей и МенеджерЗаписи . Ограничения объекта МенеджерЗаписи были описаны в разделе Добавление записей.

Общая схема редактирования записей регистров сведений:

  1. создание объекта НаборЗаписей или МенеджерЗаписи ;
  2. наложение отборов;
  3. чтение записей базы данных, соответствующих наложенным отборам;
  4. редактирование прочитанных записей;
  5. запись отредактированных записей.

// Редактирование записей с использованием объекта НаборЗаписей
НаборЗаписей = РегистрыСведений . КурсыВалют . СоздатьНаборЗаписей (); // Этап 1
// Этап 2
НаборЗаписей . Отбор . Период . Установить ( ДатаКурса );
НаборЗаписей . Отбор . Валюта . Установить ( Доллар );
НаборЗаписей . Прочитать (); // Этап 3
Для Каждого Запись Из НаборЗаписей Цикл
Запись . Курс = 57.84 ; // Этап 4
КонецЦикла;
НаборЗаписей . Записать (); // Этап 5

// Редактирование записей с использованием объекта МенеджерЗаписи
Запись = РегистрыСведений . КурсыВалют . СоздатьМенеджерЗаписи (); // Этап 1
// Этап 2
Запись . Период = ДатаКурса ;
Запись . Валюта = Доллар ;
Запись . Прочитать (); // Этап 3
Если Запись . Выбран () Тогда // Проверка, что запись существует
Запись . Курс = 57.92 ; // Этап 4
Запись . Записать (); // Этап 5
КонецЕсли;

Читайте также:  Qtech как настроить vpn

Чтение записей

Чтение информации из базы данных рекомендуется выполнять при помощи запросов. Данный способ обеспечивает гибкое применение отборов и группировок, а также возможность выбора записей из нескольких таблиц.

Запрос = Новый Запрос ;
Запрос . Текст =
«ВЫБРАТЬ
| КурсыВалют.Период,
| КурсыВалют.Валюта,
| КурсыВалют.Курс
|ИЗ
| РегистрСведений.КурсыВалют КАК КурсыВалют» ;

Выборка = Запрос . Выполнить (). Выбрать ();
Пока Выборка . Следующий () Цикл
// обход результата выполнения запроса
КонецЦикла;

Для периодических регистров сведений есть возможность получить наиболее поздние записи, период которых меньше указанной даты — срез последних, и наиболее ранние записи, период которых больше указанной даты — срез первых. Для получения среза первых и среза последних запросом необходимо использовать одноименные виртуальные таблицы, в параметрах которых сразу можно задать дату среза и отборы. Отборы, если они необходимы, рекомендуется накладывать именно в параметрах виртуальных таблиц, т.к. это позволяет ускорить выполнение запроса.

// Получение записи, у которой валюта равна значению из переменной «ВыбраннаяВалюта» и период МЕНЬШЕ или равен значению из переменной «ВыбраннаяДата»
Запрос = Новый Запрос ;
Запрос . Текст =
«ВЫБРАТЬ
| КурсыВалютСрезПоследних.Период,
| КурсыВалютСрезПоследних.Валюта,
| КурсыВалютСрезПоследних.Курс
|ИЗ
| РегистрСведений.КурсыВалют.СрезПоследних(&Период, Валюта = &Валюта) КАК КурсыВалютСрезПоследних» ;

Запрос . УстановитьПараметр( «Валюта» , ВыбраннаяВалюта );
Запрос . УстановитьПараметр( «Период» , ВыбраннаяДата );

Выборка = Запрос . Выполнить (). Выбрать ();
Пока Выборка . Следующий () Цикл
// обход результата выполнения запроса
КонецЦикла;

// Получение записи, у которой валюта равна значению из переменной «ВыбраннаяВалюта» и период БОЛЬШЕ или равен значению из переменной «ВыбраннаяДата»
Запрос = Новый Запрос ;
Запрос . Текст =
«ВЫБРАТЬ
| КурсыВалютСрезПервых.Период,
| КурсыВалютСрезПервых.Валюта,
| КурсыВалютСрезПервых.Курс
|ИЗ
| РегистрСведений.КурсыВалют.СрезПервых(&Период, Валюта = &Валюта) КАК КурсыВалютСрезПервых» ;

Запрос . УстановитьПараметр( «Валюта» , ВыбраннаяВалюта );
Запрос . УстановитьПараметр( «Период» , ВыбраннаяДата );

Выборка = Запрос . Выполнить (). Выбрать ();
Пока Выборка . Следующий () Цикл
// обход результата выполнения запроса
КонецЦикла;

Кроме чтения запросом возможно использование методов объектной модели.

Для непериодических регистров сведений:

  • Выбрать ( Отбор >, Порядок >) — выбирает записи с указанным отбором;
  • ВыбратьПоРегистратору ( Регистратор >) — выбирает все записи указанного регистратора;
  • Получить ( Отбор >) — получает ресурсы записи с отбором по всем измерениям.

Для периодических регистров сведений:

  • Выбрать ( НачалоИнтервала >, КонецИнтервала >, Отбор >, Порядок >) — выбирает записи с указанным отбором, у которых период находится между и ;
  • ВыбратьПоРегистратору ( Регистратор >) — выбирает все записи указанного регистратора;
  • Получить ( Период >, Отбор >) — получает ресурсы записи с отбором по всем измерениям и периоду;
  • ПолучитьПервое ( НачалоПериода >, Отбор >) — получает ресурсы наиболее ранней записи, соответствующей указанным периоду и отбору;
  • ПолучитьПоследнее ( КонецПериода >, Отбор >) — получает ресурсы наиболее поздней записи, соответствующей указанным периоду и отбору;
  • СрезПервых ( НачалоПериода >, Отбор >) — получает таблицу наиболее ранних записей, соответствующую указанным периоду и отбору;
  • СрезПоследних ( КонецПериода >, Отбор >) — получает таблицу наиболее поздних записей, соответствующую указанным периоду и отбору.

Удаление записей

Для удаления записи(записей) в независимом регистре сведений необходимо:

  1. создать набор записей;
  2. наложить требуемые отборы на измерения и период (если регистр периодический);
  3. записать набор записей без предварительного чтения.

НаборЗаписей = РегистрыСведений . КурсыВалют . СоздатьНаборЗаписей ();

НаборЗаписей . Отбор . Валюта . Установить ( Доллар );
НаборЗаписей . Отбор . Период . Установить ( НачалоДня ( ТекущаяДата ()));

Для удаления записей в подчиненном регистре сведений необходимо:

  1. создать набор записей;
  2. наложить отбор на регистратора;
  3. записать набор записей без предварительного чтения.

НаборЗаписей = РегистрыСведений . ЦеныНоменклатуры . СоздатьНаборЗаписей ();
НаборЗаписей . Отбор . Регистратор . Установить ( СсылкаНаДокументРегистратор );
НаборЗаписей . Записать ();

Очистка регистра сведений

Для удаления всех записей в независимом регистре сведений достаточно записать набор записей этого регистра без установки отборов:

НаборЗаписей = РегистрыСведений . КурсыВалют . СоздатьНаборЗаписей ();
НаборЗаписей . Записать ();

Запись в регистр сведений, подчиненный регистратору, возможна только при установке отбора по регистратору, поэтому для очистки таких регистров необходимо:

  1. получить перечень ссылок всех регистраторов регистра сведений;
  2. последовательно записать пустой набор записей с отбором по регистраторам из пункта 1.

Запрос = Новый Запрос ( «ВЫБРАТЬ
| ЦеныНоменклатуры.Регистратор
|ИЗ
| РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры» );

Выборка = Запрос . Выполнить (). Выбрать ();

НаборЗаписей = РегистрыСведений . ЦеныНоменклатуры . СоздатьНаборЗаписей ();
Пока Выборка . Следующий () Цикл
НаборЗаписей . Отбор . Регистратор . Установить ( Выборка . Регистратор );
НаборЗаписей . Записать ();
КонецЦикла;

Остались вопросы?
Спросите в комментариях к статье.

6 комментариев

Для этого примера интересным решением будет использовать независимый регистр сведений с индексированным реквизитом ДокументДвижение, используя его как аналог Регистратора. В этом случае можно будет получить профит при записи регистра.

Читайте также:  Как настроить зажигание муравья

Не понятно за счет чего может быть профит при записи набора записей независимого регистра сведений. Можете пояснить?

Работа платформы с регистрами сведений несколько раз менялась. 8.3 стала более оптимальной и как бы мне не хотелось «потыкать палочкой» в 8.1 и в ранние версии 8.2, дабы показать как все было плохо, решил этого не делать. Кому станет любопытно «как было» — получит мотивацию изучить вопрос.

Зачем накладывать Отбор, когда создаётся новый набор записей?

Источник

Как заставить Windows 10 распознавать регистр в именах файлов и папок

Распознавание регистра папок и файлов — функция, которая будет полезна многим пользователям. Она позволяет создавать большее количество папок с одинаковыми названиями, но разными путями. Эта особенность сыграет на руку когда нам нужно создать несколько путей с именем “документы” или же мы просто не хотим придумывать много сложных названий. Предположим, вы дизайнер и хотите сделать несколько папок для эскизов. Для этого достаточно создать первый путь “Sketch” для исходников и второй путь “sketch” для личных наработок. Далее все зависит только от творческого подхода.

Активировать функцию распознавания регистра вам поможет команда fsutil.exe . Главным нюансом ее использования является необходимость таргетного применения. Это означает, что атрибут распознавания нужно применять к каждой папке индивидуально. То есть, если вы хотите настроить пути Projects и Documents , с каждым из них придется работать отдельно.

Важно отметить:
Изменения пути C:\Program Files\”projects” не затрагивают внутренние файлы и папки. Поэтому внутри директории projects правила регистра остаются неизменными.

Включение функции распознавания регистра инструментами Windows

Чтобы включить распознавания регистра файлов и папок, нам потребуется обратиться за помощью к базовым инструментам Windows — командной строке и утилите Windows PowerShell. И если с первым инструментом все предельно ясно, то второй для пользователей часто остается загадкой.

Windows PowerShell — это приложение, разработанное компанией Microsoft для автоматизации системных задач и управления конфигурацией Windows. Утилита работает с открытым исходным кодом и поддерживается платформами Windows, Linux и MacOS. Основанная на .NET Framework программа включает в себе функционал командной строки и поддерживает скрипты.

Таким образом, в Windows 10 не играет роли какое приложение вы используете: CMD или Windows PowerShell. Выбор зависит только от личных предпочтений.

Как включить функцию распознавания регистра

1. Определите папку с которой предстоит работать и путь к ней. Для примера мы рассмотрим папку documents , расположенную по пути C:\documents .

2. Откройте Windows PowerShell от имени администратора. Сделать это можно щелкнув правой кнопкой мыши по иконке меню Пуск и найдя в появившемся окне соответствующую утилиту.

3. Введите команду fsutil.exe file setCaseSensitiveInfo C:\documents enable и нажмите Enter .
Замените часть “C:\documents” на путь к вашей папке.

4. Теперь вы можете создать две папки Documents с разными регистрами.

Отключить функцию распознавания регистра можно аналогичным способом с заменой одного лишь элемента.

1. Откройте Windows PowerShell от имени администратора.

2. Введите команду fsutil.exe file setCaseSensitiveInfo C:\documents disable и нажмите Enter .
Замените часть “C:\documents” на путь к вашей папке.

Как проверить чувствительность папки к регистру

Если вы часто пользовались данной функцией, вполне возможно, что уже возникла некоторая путаница. Иногда бывает тяжело с ходу определить какая папка редактировалась, а какая нет. Поэтому, чтобы не создавать лишней мороки и поисков, рекомендуем воспользоваться простым руководством, которое менее чем за минуту позволит вам проверить статус директории.

1. Откройте Windows PowerShell от имени администратора.

2. Введите команду fsutil.exe file queryCaseSensitiveInfo C:\documents и нажмите Enter .
Замените часть “C:\documents” на путь к вашей папке.

3. Результатом станет отображение текущего статуса папки.

Примечание:
Применяя функцию распознавания регистра к папке, содержащей файлы с одинаковыми названиями, вы гарантированно столкнетесь с ошибкой. Это действие приведет к конфликту документов. Поэтому, перед тем как включать функцию распознавания, рекомендуем удалить или переименовать файлы с дублирующимися названиями.

Настройка распознавания регистров подсистемы Windows в Linux

Особенность операционной системы Linux заключается в том, что она по умолчанию допускает возможность создания папок с дублирующимися названиями — вопрос только в регистре текста. Благодаря встроенной оболочке Bash , она же затрагивает и установленную подсистему Windows, создавая творческий простор для пользователя.

Источник

Как изменить регистр имени сайта в Яндекс.Вебмастере

Для того, чтобы поменять отображение домена сайта в поисковой выдаче Яндекса потребуется изменить регистр имени сайта, что дает возможность сделать название веб-ресурса выразительней или подчеркнуть отдельные слова.

Читайте также:  Как настроить нокиа 500

Инструкция по изменению регистра имени сайта

Воспользоваться данной функцией можно подключившись в Яндекс.Вебмастеру.

После этого потребуется пройти в раздел «Информация о сайте»-«Регистр имени сайта».

В ней будет сразу показан действующий регистр, который при необходимости можно поменять на свой, например, выделить заглавными буквами отдельные части слова и нажать на «Изменить» (в этом случае причины изменения можно оставить пустым).

После этого начнется проверка, которая может занять до нескольких недель.

В итоге получаем в поисковой выдаче вместо домена прописанное название.

Важно! Следует понимать, что не следует писать другие название сайта или подменять популярным брендом. Также рекомендуется не делать все заглавные буквы. Если же это действительно необходимо, то лучше описать полностью причину изменения.

Источник



Изменяем регистр букв в имени сайта – новая возможность от Яндекс.Вебмастер

Актуально будет для тех, у которых доменное имя, состоит из двух (или больше) слов. В предшествующем посте — как выбрать доменное имя для своего сайта, я советовал вам удержаться от соблазна использовать дефис между словами в домене, и писать их слитно.

Радуйтесь — Яндекс теперь позволяет указать какие именно символы, в имени вашего сайта, нужно выводить заглавными буквами. Согласитесь – VideoTutor.ru выглядит понятнее, чем — videotutor.ru

Конечно, работает это только в поисковой выдаче самого Яндекса.

Процесс “заказа” нового регистра для некоторых букв домена, в выдаче Яндекса, достаточно прост:

2. Выбираем “Мои сайты” или “Добавить сайт” – если ещё этого не сделали.

3. Выбираете ваш сайт, если у вас их несколько,

4. В левой колонке выберите: “Сайт в результатах поиска — Регистр имени сайта”

5. Вводите желаемый вид вашего домена в результатах поиска Яндекса

6. Вашу заявку примут к рассмотрению.

7. Теперь осталось только ждать.

Правила изменения регистра символов домена в Яндексе

Что бы буйная фантазия ВЕБ мастеров, не испортила внешний вид выдачи Яндекса, перед подачей заявки, очень рекомендую почитать какие изменения регистра в имени сайта допустимы.

Там всё очень логично и правильно обосновано.

Подал заявку на VideoTutor.ru сегодня. Жду. А мой проект JoomlaTeacher.ru – уже красуется 🙂

А как у вас с этим делом?

Related Posts

Предлагаю вам освоить создание сайта на CMS Joomla (версия 2.5) за 10 занятий. Цель –…

У вас появился первый заказчик? Поздравляю! Если он не является (по-совместительству) вашей мамой, женой (мужем)…

Каждый ВЕБ – мастер работает с FTP – протоколом. Загружает файлы на хостинг и скачивает…

Источник

Изменяйте регистр имени сайта — это привлекает внимание пользователей

В Яндекс.Вебмастере есть такой потрясающий пункт в настройках информации о сайте, называется он «Регистр имени сайта». Многие топовые сеошники и прочие мастера говорят, что этот пункт вообще не нужен, никакого эффекта для сайта он не оказывает и вообще непонятно, зачем этот пункт поместили в Яндекс.Вебмастер.

Я с этим категорически не согласен:

  1. Просто так пункты в сервисах типа Яндекс.Вебмастер не появляются;
  2. Для того, чтобы ответить, есть в чем-то смысл или нет, необходимо это дело протестировать.

Зачем менять регистр имени сайта

Сам механизм, как кажется на первый взгляд, никакой пользы не представляет: на ранжирование вашего сайта в результатах поиска это не влияет, в ТОП по ключевым словам также не поднимет.

Дело в привлечении внимания.

Например доменное имя вашего сайта состоит из двух слов: kupitmashinu.ru
Или в случае этого сайта lozhkinivan.ru

Буквы сливаются, пользователям сложно понять аббревитуру в названии домена.
Используем данный сервис.

В результате получаем следующее:
kupitmashinu.ru — KupitMashinu.ru
lozhkinivan.ru — LozhkinIvan.ru

Совсем другое дело.

Как изменить регистр имени сайта

Изменить регистр имени сайта очень просто. Для этого сайт предварительно должен быть добавлен в сервис Яндекс.Вебмастер.

  1. Заходим в сервис Яндекс.Вебмастер.
  2. Находим сайт, регистр имени которого хотим изменить.
  3. Нажимаем на этот сайт.
  4. Находим пункт «Информация о сайте», подпункт «Регистр имени сайта».
  5. Меняем регистр, исходя из особенностей.
  6. В случае с моим сайтом это выглядит так:

Что мы получим в итоге?

По 3 моим сайтам без особых изменений в выдаче по ключевым словам увеличилась посещаемость на 8% за полтора месяца.

Источник